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Let's	go	through	some	more	concrete	examples	to	add	a	plugin	and	make	use	of	the	summing	plugin	that	will	change	the	standard	behavior	of	inside	the	form	in	a	more	useful	WYSIWYG	editor.	We	could	choose	and	choose	which	plugin	to	add,	but	for	demonstration	purposes,	we	will	copy	the	entire	plugins	folder.	7.)	Fixing	Administrate	Image	Paths
Now	we	repair	the	layout	and	modify	the	packages	for	reference	to	scripts	and	styles	related	to	reference.	If	you	run	the	project	now,	you	may	notice	that	the	icons	in	the	upper	right	corner	are	missing.	The	initial	page	of	the	Administrate	model	must	now	be	displayed	as	desired	when	you	run	the	project	in	Visual	Studio.	8.)	Adding	More	Features
Using	Plugins	In	the	AdminLTE	template	The	Administrate	Control	Panel	can	make	use	of	many	plugins	to	extend	your	functionality,	graphics,	colorpicker,	datatabler,	datatables,	and	so	on.	The	heading	header	of	the	initial	page	of	the	adminThere	will	also	contain	breadcrumbs,	so	we	implemented	a	really	basic	version.	Let's	first	create	an	ASP.NET
MVC	project	using	Visual	Studio:	Start	Visual	Studio	and	select	"Create	new	project".	Let's	discuss	more	about	plugins	in	step	8.	On	line	4,	@RendSection	will	render	the	contents	of	the	@section	{}	scripts	if	the	display	contains	this	named	section.	One	way	to	achieve	this	is	testing	which	controller	and	which	view	is	current.	At	the	end	of
index.cshtml,	add	the	following:	Scripts	@section	scripts	{	document.addeventlistener	('domContentLoaded',	function	()	{var	calendarel	=	document.getelementbyid	('calendar');	var	Calendar	=	New	FullCalendar.	Calendar	(Calendarel,	{Themesystem:	'Bootstrap'});	Calendar.Render	();});	}	Similar	to	the	previous	summing	plugin,	we	use	@section	{}
scripts.	Administrate	v3.2.0	uses	jQuery	v3.6.0,	while	Visual	Studio	uses	jQuery	Oldest	in	the	ASP.NET	MVC	project.	A	"Create	a	new	ASP.NET	ASP.NET	Web	The	window	will	appear.	All	this	improves	the	time	of	loading	the	site.	Lines	1	and	2	refer	to	the	jQuery	and	bootstrap	bundles	within	the	MVC	project,	while	line	3	refers	to	the	scripts	related	to
adminTRE.	The	2nd	level	of	bread	flour	simply	generates	a	title	for	the	current	page	(line	14).	Let's	add	this	plugin	next.	Now,	let's	focus	on	the	content	itself.	If	you	are	already	inside	Visual	Studio,	go	to	File>	New>	Project.	In	VS,	Go	to	Solution	Explorer,	click	the	right	mouse	button	on	your	project	and	select	Add>	New	folder.	Check	this	solution	to
correct	the	problem.	You	can	look	into	the	main	.js	file	or	.css	from	the	plugin	folder	in	the	Plugins	folder	to	locate	the	official	link	of	the	plug	-in.	Now	that	the	plug	files	were	copied	into	our	project,	we	can	finally	refer	to	styles	of	fontes	that	are	used	â	€	â	€	Remove	the	two	elements	and	replace	it	by:	home	Highlighted	yellow	lines	show	the	changes
we	made	in	comparison	with	the	original	HTML	code.	Let's	copy	this	folder	into	our	project	in	Visual	Studio.	Then	let's	add	a	simple	contact	form.	Within	the	2nd	Add	the	following	code:	This	will	be	a	division	containing	the	calendar.	4.)	Changing	the	ASP.NET	layout	to	the	Administrate	Used,	we	will	use	the	Administrate	Starting	page	to	replace	the
current	Layout	content	of	the	ASP.NET	MVC	project.	The	second	line	refers	to	the	main	administration	styles	that	were	added	when	we	copied	the	contents	of	the	Dist	folder	in	step	3.	You	may	be	wondering	why	the	code	is	involved	inside	the	@section	scripts	{}	block.	At	the	tag:	The	first	line	makes	reference	to	styles	for	the	Fontawesome	icon
library.	If	we	look	at	the	example	of	SummerNote	Bootstrap	4,	we	can	see	that	it	uses	SummerNote-Bs4.js	for	script	file	and	SummerNote-Bs4.Css	for	Styles.	2.)	Getting	GitHub	Administrate	Files	Go	to	Administrate	GitHub	Liberation	Page,	Find	AdminLTE	V3.2.0,	make	the	code	download	-Fon	and	extract	the	files	somewhere	of	your	computer.	The
"Create	a	New	Project"	window	will	appear	with	the	list	of	available	templates.	For	the	most	basic	example,	check	the	page	boot	with	script	tags.	6.)	Add	Scripts	and	Administrate	Styles	to	Packages	in	Solution	Explorer,	Go	to	App_start>	BundLeconfig.cs.	A	display	changes	window	can	open	by	showing	the	changes	that	Visual	Studio	will	do	with	the
solution.	Find:	in	,	delete	everything	in	it	and	replace	it	by:	class	=	"linha	mb	-2	">	@viewbag.title	@if	@if	!	=	"Home"	||	@	ViewContext.Routedata.Values	​​â	€	bundleconfig.cs	and	inside	the	bundles.add	(),	find	the	line	that	adds	the	admin	scripts.	Select	the	installed	tab	that	will	list	the	currently	installed	libraries.	Inside	him,	we	found	packages
already	added	by	Visual	Studio	to	jQuery,	Modernizer	and	Bootstrap.	The	Adminlete	uses	the	Fontawesome	plugin	to	show	them	and	we	will	add	this	plugin	to	the	next	section,	but	first,	we	will	learn	a	little	more	about	the	plugins	in	general.	It	is	similar	to	the	Master	Página	of	ASP.NET.	The	end	result	will	look	for	something	like	this:	Click	Picture	to
enlarge	There	is	an	available	administrative	nuget	package,	but	it	was	not	updated.	Then	we	will	get	the	necessary	github	page	files	admin	and	copy	these	files	into	our	project.	project.	These	two	lines	and	replace	them	by:	@	Styles.Render	("~	/	CSS")	@	scripts.Render	("~	/	bundles	/	modernizr")	So,	what	are	@	styles.Render	and	@	scripts.Render.
All	that	is	still	required	is	to	include	these	two	files	in	our	packages.	Let's	edit	the	App_start	file>	bundleconfig.cs	a	little	later.	We	only	need	to	add	a	script	that	incorporates	the	calendar.	Now,	let's	define	which	files	include	when	@	styles.render	()	and	@	scripts.Render	()	are	called.	AdminTrette	V3.2.0	uses	bootstrap	v4.6.1,	while	the	ASP.NET	MVC
project	uses	the	oldest	bootstrap	v3.4.1.	We	can	check	which	libraries	versions	the	ASP.NET	MVC	USA	project,	updates	to	more	recent	versions	or	install	additional	libraries	using	the	Manage	NUGETT	packages	tool.	Filter	&	Refine	27	Results	Clean	All	Analytics-Event	#	SendFilterPanelEvent	Click->	Toggle	#	Alternating	Data-Toggler-Target	=
Toggle	Data-Toggler-Expanded-Aria-Label	=	Collapse	Filter	Data-Togggler-Colapsed-Aria-Label	=	Expand	Aria-Label	Filter	=	Expand	Category	Filter	Data-Analytics-Event	=	{"Hittype":	"event",	"Eventaction":	"Click",	"EventLabel":	"Category"}>	All	categories	27	site	templates	20	courses	6	Marketing	1	Analytics-Event	#	SendFilterPanElevent	Click->
Toggler	#	Switch	Data-Toggle-Toggler-Target	=	Toggle	Data-Toggler-Expanded-Aria-Label	=	Collapse	Prepare	Filter	Data-Toggler-Collapsed-Aria-Label	=	Expand	Price	Filter	Data-Analytics-Event	=	{"Hittype":	"EventAction":	"EventAction":	"Click",	"EventLabel":	"PREQUE"}>	Analytics-Event	#	SendFilterPanelEvent	Click->	Toggle-Toggle-Toggle
Switch	Data-	Toggler-expanded-aria-label	=	collapse	on	sales	filter	data-toggler-colllassed-aria-label	=	expand	on	the	sale	filter	aria-lain	=	expand	on	the	D	filter	and	sell	data-analytics-event	=	{"hittype":	"event":	""	""	Eventaction	":"	Click	","	EventLabel	":"	Discount	"}>	Analytics-Event	#	Click->	Toggle	#	Toggle	Data-Toggler-Target	=	Toggle	Data-
Toggler-Expanded-Aria-Label	=	colapso	Filtro	Filtro	Aria-Label	Sales	Filter	=	Expand	the	sales-event-event-event-event	data	=	{hittype	":"	event	","	EventAction	":"	Click	","	EventLabel	":"	Sales	"}>	Analytics-Event	#	SendFilterPanelEvent	Click->	TOOTEGLER	#TOGBLE	DATA-TOGGLER-TARGET	=	Switch	Data-Toggler-Expanded-Aria-Label	=
Collect	compatible	with	Filter	Data-Toggler-Collesed-Aria-Label	=	Expand	Compatible	with	Aria-label	filter	=	Expand	compatible	with	event	of	Analytics	of	filter	data	=	{"hittype":	"event",	"eventaction":	"Click",	"EventLabel":	"Compatible	-	with"}>	asptudio	is	the	new	model	of	administration	of	the	study	and	totally	Responsive	5,	which	built	on	top	of
the	popular	structure.	NET	CORE	5.0	MVC.	The	first	is	to	replace	the	next	(alt	+	r),	while	the	second	is	to	replace	everything	(alt	+	a).	We	can	quickly	achieve	this,	including	a	clustered	bootstrap	versus	regular.	But	there	are	more	sophisticated	models	with	prolonged	functionality	available.	Click	OK	and	wait	for	the	finish	installation.	The	end	result
should	be	like	this:	CONCLUSION	Creating	an	ASP.NET	MVC	project	in	Visual	Studio,	we	received	a	Web	application	using	the	Front-End	Bootstrap	structure.	Adding	a	calendar	on	index.cshtml	Open	the	displays>	Initio>	Index.cshtml	file.	It	should	contain	three	folders:	CSS	-	containing	IMG	styles	-	containing	js	-	containing	JavaScript	files	in	one
minute,	let's	copy	them	to	a	visual	studio,	but	before	we	do	this,	we	will	make	a	new	folder	in	our	project.	As	mentioned	earlier,	packets	are	located	in	the	App_start>	Bundleconfig.cs	and	we	will	edit	this	file	in	the	next	step.	To	learn	more,	check	this	MSDN	page.	On	the	left	side,	we	can	choose	between	different	ASP.NET	models.	When	using



@section	{}	scripts	in	index.cshtml,	we	certify	that	the	script	code	above	will	only	be	included	when	the	index.cshtml	display	is	displayed.	8c.)	Adding	plugin	fullcalendar	to	the	The	first	step	is	to	visit	the	FullCalendar	official	website	and	seek	to	look	for	on	how	to	install	the	plugin.	Let's	add	this	to	our	project	at	Step	8	and	Step	8a.	Within	Windows
Explorer,	we	need	to	climb	a	novel	from	the	Dist	folder,	so	we	are	in	the	Root	"Adminlte-3.2.0"	folder	of	the	extracted	files.	It	comes	to	the	folder	containing	extracted	files	we	received	from	Github	and	see	for	the	Dist	folder.	We	can	still	use	site.css	to	add	our	personalized	styles.	Open	the	app_start	folder>	BundleConfig.cs	file	and	insert	the	following
yellow	Code	outstanding	(Line	3)	for	the	existing	style:	Bundles.add	(New	Stylebundle	("~	/	CSS	/	CSS").	Include	("~	/	containment	/	bootstrap.	CSS	"",	"~	/	adminlte	/	plugins	/	fontawesome-free	/	css	/	all.min.css",	"~	/	adminlte	/	css	/	adminlte.min.css",	"~	/	containment	/	site	/	site.css")	;	And	we	end.	Remove	everything	from	_layout.cshtml	and
replace	it	with	the	count	of	Starter.html.	First,	we	need	to	update	the	JQuery	&	Bootstrap	JavaScript	libraries	currently	used	in	the	ASP.NET	MVC	project.	ÃCones.	Select	the	versions:	Hang	menu	and	choose	the	version	of	JQuery	3.6.0:	Click	on	the	update.	Solutions	for	this	problem.	We	still	need	to	incorporate	it	into	our	Page.	When	you	finish,	the
ADMINLTE	folder	in	Solution	Explorer	should	be	like	this:	Now,	you	need	Let	us	referencing	scripts	and	plug-in	styles	in	app_start>	bundleconfig.cs,	depending	on	the	plugins	we	want	to	include.	You	can	also	use	drag	and	release	instead	of	copying	/	paste.	Now	find	the	Starter.html	file	and	open	it	in	Visual	Studio	or	some	other	text	editor.	We	will	do
this	next	when	we	become	our	attention	to	the	contact	pad.	If	we	look	at	Plugins>	FullCalendar	Folder	at	Solution	Explorer,	we	can	see	that	a	script	main.js	file	and	a	main.css	file.	Let's	use	this	id	to	incorporate	the	Use	what	you	want	to	replace	all	distance	instances	/	img	/	in	~	/	adminlte	/	img	/.	Finally,	we	created	we	created	Simple	form	in	the
contact	page	that	uses	a	WYSIWYG	editor	and	also	added	a	calendar	on	the	initial	page.	It	is	located	in	the	Content>	Site.css.	In	this	article,	substitute	for	the	control	/	control	panel	control	template.	Below

@	viewbag.message	Enter	the	following	code:	@using	(html.beginform	()	{	@	html.label	("name")	@	html.textbox	("personalist",	null,	new	{@class	=	"form-control",	@	style	=	"width:	200px	"})	@	html.label	("	comment	")	@	html.textaea	("	CourcialComment	",	new
{@class	="	textarea	",	@id	=	"Summing"}	send	}	<	/	div>	Make	sure	that	the	Textarea	field	uses	ID	=	"Summante"	(line	11).	3.)	Copy	files	from	Visual	Studio	Now	we	will	copy	the	required	files	for	our	ASP	project.	Net	in	Visual	Studio.	There	is	also	a	Fontawesome
library	included	there	that	we	will	need	to	add	so	that	the	admin	works	as	desired.	Click	the	OK	button	to	continue.	Then	let's	reference	SC	RIPTS	and	styles	of	only	those	plugins	that	we	want	to	use	in	the	Administrate	panel,	editing	the	App_start>	bundleconfig.cs
file.	8A.)	Adding	Fans	in	the	ASP.NET	MVC	Project	To	make	fontawesome	icons	work	on	our	project,	we	need	to	add	an	all.min.cs	style	located	in	Administrate>	Plugins>	Fontawesome-Free>	CSS	folder	in	the	packages.	In	Windows	Explorer,	you	will	go	to	the	extract
files	folder	that	we	receive	from	the	GitHub	and	drag	and	drop	or	copy	/	paste	the	Windows	Explorer	plugins	folder	into	Visual	Studio	project	within	the	AdminTR	folder.	8b.)	Adding	the	Summing	plugin	in	the	ASP.NET	MVC	project	again,	we	need	to	add	the	required
scripts	and	styles	in	the	packages	located	in	the	App_start>	bundleconfig.cs.	For	the	ASP.NET	MVC	project,	the	main	layout	file	is	the	_layout.cshtml,	_layout.cshtml	file,	Layout	View	Located	in	Views>	Shared>	_layout.cshtml.	When	a	vision	is	rendered	and	contains
the	@section	{}	scripts,	the	contest	in	it	will	be	inserted	before	tag.	Visual	Studio	copies	them	in	the	project.	Any	technique	you	used,	the	ASP.NET	project	in	Solution	Explorer	should	now	look	like	this:	now	that	we	copy	the	necessary	files,	we	will	focus	on	the
Dashboard	Administrate	layout.	Before	the	end	Tag	find:	Replace	these	rows:	@	scripts.Render	("~	/	bundles	/	jQuery")	@	scripts.Render	("~	Bundles	/	bootstrap	")	@	scripts.Render	("	~	/	adminTE	/	js	")	@Rendersion	("	Scripts	",	needed:	False)	So,	what	did	we	do	here?
Use	WYSIWYG	Summary	Plugin	Editor	on	the	Contact	Painting	in	Solution	Explorer,	Open	Views>	Initium>	Contact.Cshtml.	In	the	previous	step,	we	copied	the	contention	of	the	D	folder	using	Windows	Explorer	in	a	Visual	Studio.	},	then	all	the	most	not	wrapped	in
them	will	be	rendered	by	@Renderbody	().	We	added	the	yellow	highlighted	line:	bundles.add	(new	scriptbundle	("~	/	admin	/	js").	Include	("~	/	AdminClte	/	js	/	adminlte.js",	"~	/	admin	/	plugins	/	fullcalendar	/	main.js"	"	~	/	AdminTE	/	plugins	/	summing	/	summing-
bs4.js	"));	Script	and	style	files	will	now	be	loaded.	Name	this	Admin	folder.	On	the	right	side,	in	"advanced",	there	will	be	a	selected	selection	box	for	"Configuring	HTTPS".	Visual	Studio	will	create	a	self-signed	SSL	certificate	so	that	we	can	develop	HTTPS
applications,	but	if	you	run	the	project	in	Firefox,	you	can	get	the	"Secure	Connection	Failure"	error	message.	5.)	Adding	a	missing	razor	Layout,	we	need	to	add	the	razor	code	inside	the	tag	and	the	tag.	All	major	main	visions	About.cshtml,	contact.cshtml)	generated
by	Visual	Studio	for	the	ASP.NET	MVC	Initium	project	with	the	following	line:	@	{viewbag.title	=	"page	name";	}	So	we	used	the	viewbag.title	on	line	3,	which	will	display	the	current	page	title	in	the	context	header.	But	there	are	few	shaving	code	lines	and	some
additional	lines	inside	_layout.cshtml	we	still	need,	then	in	the	next	section,	let's	add	them	back	to	our	new	layout.	Also	we	have	navigation	links	in	the	sidebar	menu:	Find:	inside	it,	you	will	see	tags	àcoras	with	a	tag	in	them.	The	concept	of	design	for	Aspstudio	is
based	on	the	flat	design	and	finally	comes	out	with	a	clean	and	clean	design.	You	can	click	with	the	right	mouse	button	on	three	folders	in	Windows	Explorer	and	select	"Copy"	and	click	the	right	mouse	button	in	the	AdminTR	folder	in	the	VS	Solution	Explorer	and
select	Necklace.	Version:	For	jQuery	should	now	show	3.6.0.	Now,	let's	focus	on	adding	administrators	to	our	ASP.NET	MVC	project.	To	correct	the	images,	we	need:	Open	views>	shared>	_layout.cshtml.	Inside	the	tag	we	have	navigation	links	and	let's	make	them
using	the	razor	code:	find:	Casa	Replace	it	by:	@	Html.ActionLink	("Home",	"index",	"Home",	null,	new	{@	class	=	"nav-link"})	Find:	Contact	and	replace	it	by:	@	Html.ActionLink	("	Contact	","	Contact	","	Home	",	null,	new	{@	class	="	nav-link-link	"})	A	resource	we
are	Missing	here	is	to	add	an	active	bootstrap	class	to	or	@	html.aCtionLink	()	when	the	link	is	the	same	as	the	current	page.	You	can	do	this	in	different	ways.	Bundling	was	added	to	ASP.NET	4.5.	With	this	feature,	we	can	gather	several	script	/	style	files	on	a	single
file	and	also	to	minify	them.	In	the	Search	field,	type	MVC	and	select	Web	Application	(.NET	Framework)	"and	click	Advance.	But	there	is	still	something	to	repair	with	the	layout,	which	is	the	way	of	A	-visualization	window	will	be	open	again.	Now,	open	Windows
Explorer	and	go	to	the	DIS	folder	and	copy	all	three	folders	into	the	New	Administrate	folder	created	within	Solution	Explorer	in	Visual	Studio.	It	is	also	dependent	on	page	plugin	AdminLTE	for	more	information	about	the	used	plugins	â	€	â	€
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